Up again

드디어 다시 블로그 서버를 살렸다.

블로그를 위해 http, mysql, php 서버 용으로 사용하고 있는 MAMP를 업데이트 한 이후 제대로 동작하지 않는 듯 해서 며칠 간 골치 아팠는데 원인은 그게 아니라 OSX server랑 http port 가 충돌나서 그랬다는.
OSX server 앱에서 확인했을 때 분명히 web service가 꺼져있었는데도 여전히 아파치 서버가 떠 있어서 80번 포트를 점유하고 있었다는 점. 문제(?)는 간단한 관리를 추구하는 MAMP 특성 상 그냥 웹 서버 “안 떠요~” 라고만 표시하고 끝이라는 거. 웹 서버 안 뜨는 거야 이유가 뻔하긴 했지만 그래도….

참고로 OSX 에서 특정 포트를 사용하는 프로세스를 찾으려면 리눅스에서의 netstat -atp |grep XX 와가 아니라 lsof 명령을 사용해야 한다고

sudo lsof -i :80

구글링을 해서 OSX 서버의 내장 httpd 를 동작하지 않도록 하는 명령을 찾아 사용했더니 다행히 MAMP의 웹 서버가 뜬다.

sudo launchctl unload -w /Applications/Server.app/Contents/ServerRoot/System/Library/LaunchDaemons/com.apple.serviceproxy.plist

출처 : How do I stop httpd

그런데 여전히 안되네..

또 한참(?)을 고민 끝에 DNS 정보를 찾아보니 그새(?) 집 WAN 포트에 할당된 IP가 바뀐 듯 하다. 새로 받은 IP 정보를 업데이트하도록 DNSever 사이트의 정보를 변경하니 이제 제대로 블로그까지 접속되네.

Disk 1 failed

요 며칠 NAS가 혼자 꺼지는 경우가 2번 있었는데 지난 번 처럼 정전으로 꺼졌나 생각했는데 그게 아니었나보다. 오랜만에 관리자 창에 들어가 보니 2개 DISK중 disk 1에 접근하는데 에러가 발생했다고

며칠 껐다 다시 켜서 백업을 하려고 보니 또 괜찮아 보인다.

그래서 또 며칠 그냥 썼는데 다시 혼자 꺼지길래 켰더니 이젠 아예 disk 1이 인식이 안된다.

아주 갔나 보다. 영영 -_-;;;

두 개의 하드를 지원하는 2 bay NAS라서 첫번째 하드에는 데이터를 담고(주로 사진들) 두 번째 하드에는 첫번째 하드의 사진 등을 백업하는 용도로 사용했는데 첫번째 하드가 맛이 가버린 거다.
사진은 미리 다른 2TB 외장하드를 원본으로 삼아서 NAS의 disk 1에 주기적으로 복사를 하고, NAS 내부 백업 기능을 이용해서 disk 2에 주기적으로 자동 백업이 되게 해 놨다. 그래서 가장 중요한 사진 자료만 보면 3군데의 데이터 저장소 중에 한 곳이 망가져버렸지만 나머지 2군데에 아직 데이터가 남아있다. 하지만 두 군데 모두 물리적인 하드디스크라 동시에 3군데가 모두 망가져 버리는 경우도 배제할 수가 없다.

사진의 경우 Amazon Prime 멤버십을 사용하면 주어진 사진 저장 공간을 이용해서 백업을 해 놨는데 이 서비스가 사진에 대해서는 무한대 공간을 제공하지만, 동영상은 그렇지 않다. 최근에 사진 찍는 패턴은 사진과 함께 동영상도 찍는 거라 이 경우 백업이 안되는 거다(물론 사진은 계속 업로그가 허용되지만)

아무래도 Amazon Drive를 신청해서 마음의 안정을 얻어야겠다는 생각이 든다. 1년에 60불인데 휴… Amazon Prime 멤버는 좀 싸게 해주는 거 없니?